1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Настройка роутера D-Link DIR-300A

Настройка роутера D-Link DIR-300A. Подробная инструкция

В этой инструкции мы будем настраивать популярный маршрутизатор D-Link DIR-300A. Это недорогой роутер для домашнего использования. В отличии от D-Link DIR-300/A/D1, который уже снят с производства, новая модель выпускается в новом очень необычном корпусе в виде цилиндра. Приятно, что за такую цену можно приобрести маршрутизатор в таком необычном корпусе.

Я планирую в ближайшее время подготовить статью с советами по выбору бюджетного роутера для дома. Собственно по этой причине я и приобрел D-Link DIR-300A. Так как он по всем параметрам подходит для домашнего использования, и относится к бюджетным моделям. Сам роутер мне понравился. Необычный корпус, хорошее качество сборки, понятная панель управления, и даже резиновые ножки, что в бюджетных моделях большая редкость.

Что касается настройки этой модели, то сам процесс практически ничем не отличается от настройки другим маршрутизаторов D-Link. Но я решил подготовить отдельную инструкцию, в которой показать и рассказать о всех нюансах. Покажу как подключить DIR-300A, как зайти в настройки, настроить роутер на подключение к интернету, настроить Wi-Fi сеть, сменить пароль и т. д. Думаю, эта информация пригодится многим. Тем более, что инструкция которая идет в комплекте не очень информативная.

Настроить маршрутизатор можно практически с любого устройства, даже с телефона, или планшета, подключившись по сетевому кабелю, или по Wi-Fi. Но, если у вас есть стационарный компьютер, или ноутбук, то настраивать роутер я советую именно с этих устройств. И лучше всего на момент настройки подключится к DIR-300A по сетевому кабелю.

Смена заводского пароля

В целях безопасности рекомендуется сменить заводской пароль.

По умолчанию: Логин admin, пароль admin.

В интерфейсе роутера необходимо зайти во вкладку Система (System), меню Пароль администратора (Administrator password).

В поле Пароль (New Password) введите новый пароль.

В поле Подтверждение (Confirm Password) повторите новый пароль.

Затем нажмите кнопку Сохранить (Save Settings).

После этого, роутер предложит повторно зайти в его настройки.

Протоколы группы FHRP (First Hop Redundancy Protocols)

FHRP (Протокол резервирования первого перехода) — это группа протоколов способные обеспечить клиентов отказоустойчивым шлюзом.

Что за первый переход такой?. У нас есть коммутируемая среда (SW1) и есть Internet . Internet это маршрутизируемая среда . И для того чтобы перейти из коммутируемой среды , в маршрутизируемую среду для того чтобы выйти в интернет , как раз эти роутеры(R1,R2,VR — Virtual Router) обеспечивают данный переход и для того ,чтобы обеспечить отказоустойчивость этого перехода , его нужно резервировать . А потому и называется протоколы резервирования первого перехода.

И все протоколы группы FHRP будут работать в единой логике: R1 , R2 будут прикидываться VR и в случае отказа одного из маршрутизаторов, то его работу возьмет другой.

  • Forwarding Router ( FR ) — это роутер ,который данный момент активен и маршрутизирует трафик .
  • Standby Router ( SR ) — это роутер ,который стоит в резерве и ждет , когда накроется FR ,чтобы перехватите его работу на себя , в случае сбоя маршрутизатора.
  • FHRPs — это группа ,а значит пришло время познакомить вас с этими протоколами.
    • HSRP (Hot Standby Router Protocol) — Проприетарный протокол разработанный Cisco;
    • VRRP (Virtual Router Redundancy Protocol) — Свободный протокол ,сделан на основе HSRP;
    • GLBP (Gateway Load Balancing Protocol) — Проприетарный протоколCisco , обеспечивающий распределение нагрузки на несколько маршрутизаторов( шлюзов) используя 1 виртуальный адрес.
    • CARP( Common Address Redundancy Protocol) — свободный , разработан как часть OpenBSD , портирован во FreeBSD.

Итак начнём с HSRP

Коротко табличка с адресацией:

Протокол HSRP рассчитан на 2 роутера, 3 это уже лишний и с этим уже справиться протокол GLBP

Предположим ,что R3 это маршрутизатор выхода в интернет и для этого мы поднимем на нём Loopback 1 с адресом 200.200.200.200 и пропишем его в маршруте по умолчанию. Между маршрутизаторами будет настроен RIPv2 и будут анонсированы 2 классовые сети( network 10.0.0.0 и network 192.168.0.0) для простоты анонсирования маршрутов.

R2,R0 настраивается также. А теперь по порядку , настроим HSRP:

  • Router(config)# interface fa 0/1 — переходим на интерфейс fast ethernet 0/1 (этот интерфейс смотрит в локальную сеть на коммутатор )
  • Router(config-if)# ip address 192.168.0.2 255.255.255.0 — задаем ip адрес для физического интерфейса
  • Router(config-if)# standby 1 ip 192.168.0.254 — задаем виртуальный ip адрес (который будет основным шлюзом для свитчей, смотрящих на конфигурируемый роутер). У обоих роутеров он одинаковый
  • Router(config-if)# stanby 1 priority 110 — устанавливаем приоритет данного роутера в 110 (по умолчанию приоритет 100)
  • Router(config-if)# standby 1 preempt — задаем режим приемтинга
  • Router(config-if)# standby 1 authentication md5 key-string MyPassword — задаем аутентификацию, если необходимо. Пароль будет передаваться с защитой алгоритмом хеширования md5, пароль будет MyPassword
  • R3(config-if)# standby 1 timers 100 255 — регулировка таймеров hsrp, где 100 — hello интервал в секундах (как часто посылаются пакеты hello пакеты keep-alive) и 255 — hold interval в секундах (через какой промежуток времени признавать соседа недоступным)
  • Router(config-if)# standby 1 preempt delay minimum 300 — настройка времени задержки (в секундах), через которое роутер будет становиться главным. Эта команда требуется для того,чтобы сначала отработали другие протоколы,прежде чем заработает HSRP . Пример: OSPF включенный на роутере в большой сети не успеет передать маршруты все ,а тут сразу заработает HSRP ,естественно он знать все маршруты не будет,а значить и стабильно гнать трафик тоже. Как раз время delay он будет использовать для того,чтобы дать OSPF передать все маршруты и после этого вкл HSRP.

TRACKING

Также полезно вешать TRACK на интерфейсы ,так как HSRP работает только в сторону ,куда направлен интерфейс ,то он не сможет отработать,когда упадут линки ,смотрящие на роутеры выше.(в данном случае это R3)

  • Router(config)# track 1 interface fa0/1 line-protocol — отслеживаем состояние интерфейса fa0/1, если он падает, то сработает объект отслеживания track 1.
  • Router(config-if)# standby 1 track 1 decrement 15 — если сработает объект отслеживания track 1, то текущий приоритет будет понижен на 15 единиц.
  • Router(config-if)# standby 1 track 1 fa0/1 20 — работает только в HSRP. Позволяет отслеживать интерфейс без дополнительного создания объекта отслеживания.
Читать еще:  Что значит удалить контент на андроиде

R1,R2,R0 будут настраиваться одинаково, принцип сохраняется.

А теперь нюансы HSRP

При работе нескольких VLAN , HSRP может идти трафик не совсем рационально. Представим ,что R1 это root primary за 10 VLAN, а R3 это ACTIVE router в HSRP . Это значит ,что любой трафик за этот VLAN будет идти следующим образом:VPC — R3 — R1 — R4 вместо того,чтобы идти напрямую VPC — R3 — R4

Поэтому рекомендуют использовать HSRP version 2(по умолчанию вкл 1 максимум 255 процессов,а во 2 их 4095) и использовать наилучший приоритет для того роутера, который сейчас в сети root primary за текущий VLAN. И хорошей практикой будет если номер VLAN будет совпадать с номером процесса HSRP. ( № HSRP = VLAN )

3 Роутера в HSRP не имеет смысла держать,так как он всё равно будет в состоянии Listen и включиться только тогда,если active пропадет, standby займет его место , и только тогда он перейдет в состоянии standby.(речь идет о 3 роутере) Тоже самое будет касаться 4,5 . n роутеров.

Бывает и другая ситуация ,когда не сам линк от R1 падает ,а устройство находящиеся за ним,к примеру SW2 упал link до R3. Проблему способен решить сервис SLA — Service Level Agreement.

Суть его проста,он ping сервис до провайдера и если он падает ,то отрабатывает track.

  • Router(config)# ip sla 1 — создаем зонд
  • Router(config-ip-sla)# icmp-echo 215.215.215.2 source-interface e0/2 — посылаем icmp echo ping на 215.215.215.2
  • Router(config-ip-sla-echo)# frequency 10 — посылаем icmp echo ping с частотой каждые 10 секунд
  • Router(config)# ip sla schedule 1 start-time now life forever — задаем расписание работы ip sla. В данном случае зон будет запущен прямо сейчас, при этом время окончания не задано (навсегда)
  • Router(config)# track 1 ip sla 1 reachability — устанавливаем объект отслеживания на доступность того хоста, на который посылаем icmp echo ping
  • Router(config)# ip route 0.0.0.0 0.0.0.0 2.2.2.2 track 1 — направляем трафик по этому маршруту если объект трекинга track 1 работает (хост пингуется)
  • Router(config)# ip route 0.0.0.0 0.0.0.0 3.3.3.3 10 — если не пингуется, направляем трафик в интернет по другому маршруту (Внимание! Здесь важно задать именно плохую метрику, например 10, иначе будут работать оба маршрута! (балансировка))
  • Router# show track 1 — показать состояние объекта отслеживания

Настройка VRRP не сильно отличается от HSRP . Настраивается он также как и HSRP, только вместо standby используется vrrp. Router(config-if)# vrrp 1 ip 192.168.1.1 — включение vrrp. Проще пройтись по отличиям ,чем заново описывать все команды.

  1. У VRRP тоже только 2 состояния Master и Backup(HSRP active и standby)
  2. Preempt включен по умолчанию (HSRP он отключен)
  3. При падении линка VRRP проводит выборы роутера(HSRP имеет запасной). Главного выбирают по IP адресу, когда проводят выборы.
  4. Поддержка Аутентификации в VRRP отсутствует (RFC отсутствует),но в Cisco она реализована(HSRP по умолчанию)
  5. VRRP по умолчанию hello таймер равен 1 секунде , dead таймер равен 3(у HSRP 3 и 10 соответственно)
  6. Виртуальный адрес может совпадать с адресом интерфейса(HSRP такой адрес не даст прописать)
  7. Использует Multicast HSRP равен 224.0.0.2 ( version 1) 224.0.0.102 (version 2) ,а VRRP 224.0.0.18
  8. Может отслеживать только объекты , а HSRP и интерфейсы , и объекты.(смотри раздел tracking)

Чт июл 09, 2020 22:19:53

Через SDK и gcc можно писать «напрямик». Только полного ДШ нет, т.к. радиомодуль и wifi стек закрыты. Как и везде, в любом ус-ве с WiFi. Но писать без «библиотек» на голом bare meta вполне можно.

По остальному — мне не нужно быстрое время отклика. На деле меня хоть минута устроит. И трафик меня в 2020 году совсем не волнует. Но если нужно было бы, то есть Websockets. Там и отклики миллисекундные будут и трафика мало.
Вы как с луны свалились. Весь мир уже живет с облаками и IoT, а вас до сих пор трафик на это дело волнует.

Настройка L2TP подключения

  1. В поле Тип соединения: выберите L2TP + Динамический IP
  2. В поле Порт выбираем WAN-порт — он там указан как Port 5.
  3. Имя пользователя: Ваш логин из договора
  4. Пароль: Ваш пароль из договора
  5. Подтверждение пароля: повтор пароля
  6. Адрес VPN-сервера: пропишите адрес VPN-сервера провайдера
  7. Алгоритм аутентификации: Auto
  8. Keep alive — ставим галочку для постоянного подключения
  9. MTU — поменяйте значение на 1450 или меньше

В поле Разное проверьте, чтобы стояли галочки NAT и Сетевой экран.

Если провайдер предоставляет услугу интернет телевидения, поставьте галочку Включить IGMP.

Нажмите Сохранить;.

Настройка GRE

Первым шагом рассмотрим простую настройку gre туннеля. Вся она будет одинакова на обоих роутерах. Подключившись к нажим железкам через Winbox и перейдем в Interfaces – GRE Tunnel.

Создадим по интерфейсу. Укажем следующие параметры:

  • Name – понятное имя;
  • Remote Address – адрес соседа по туннелю. Основной принцип — направляем роутеры друг на друга;

Keepalive – тот самый параметр отслеживания состояния. Можно ничего не менять. Он означает следующее – если в течении 10 попыток по 10 секунд не отвечает удаленная сторона, считать туннель не активным.

Сохраняем настройки и смотрим на состояние.

Как мы видим, интерфейс в состоянии running. Назначим адреса. Переходим в IP – Addresses.

Зададим адрес 172.16.25.1 для московского роутера и 172.16.26.2 для питерского.

Для проверки связи запустим ping запросы.

Пинги идут – все хорошо. Далее пропишем маршруты в локальные сети. Открываем IP – Routes на московском.

Добавляем новый маршрут:

  • Dst. Address – 192.168.10.0/24;
  • Gateway – 172.16.25.2.

Сохраняем и проделываем аналогичную операцию только на питерском роутере.

Основной принцип – прописать маршруты в сети через адреса в туннелях. Проверим ping до адреса бриджа Mikrotik в Москве.

Читать еще:  Аудиоустройства отсутствуют Windows XP что делать

Все отлично – значит мы правильно сделали. В целях демонстрации я отключу интерфейс в Москве, выжду интервал в 100 секунд и посмотрим на состояние туннеля.

Интересная ситуация, в одном офисе интерфейс активный, а в другом нет. Попробуем проверить связь.

Пингов нет, а туннель активен. Спустя какое-то время, Mikrotik в Питере понимает, что связи через gre туннель нет и меняют статус на интерфейсе.

Тут-то и помогла доработка Mikrotik с keepalive. К чему этот эксперимент спросите вы? Во-первых – для демонстрации, во-вторых – если есть те, кто еще используют данный протокол для своих задач, имейте ввиду, что маршруты в routes буду активны то время, которое вы указали в keepalive. Только по истечении этого времени маршруты и адрес станут не активны.

Настройка подключения к интернету

Очень важно правильно настроить наш D-Link DIR-300A на подключение к интернету. Если роутер не сможет подключится к интернет-провайдеру, то он не сможет раздавать интернет. Без этого не смысла продолжать настройку.

Если у вас тип подключения Динамический IP (без привязки по MAC-адресу) , и вы уже подключили кабель от провайдера к роутеру, как я показывал на фото выше, то интернет через маршрутизатор уже должен работать. В настройках, прямо на на главной странице можете посмотреть статус подключения. Если он уже зеленый, то все Ok. Пропускаем этот раздел, и переходим к настройке Wi-Fi сети.

Зеленый значок говорит о том, что роутер уже подключился к интернету.

Клонировать MAC можно на вкладке WAN, выбрав нужное подключение.

Если у вас провайдер Билайн, который использует тип подключения – L2TP, или ТТК, Дом.ru, Ростелеком у которых тип подключения – PPPoE, то здесь уже нужно задать некоторые параметры.

Среди украинских провайдеров самые популярные: Домашний Интернет Киевстар – тип подключения Динамический IP. Провайдер Воля, там так же Динамический IP, но помоем с привязкой по MAC-адресу.

D-Link DIR-300A: настройка подключения L2TP на примере провайдера Билайн

Перейдите в настройках на вкладку «Сеть» – «WAN». Поставьте галочки возле подключений, которые там есть, и нажмите кнопку «Удалить». Затем, нажмите на кнопку «Добавить».

Дальше выберите тип подключения, который использует ваш провайдер. Для Билайна это «L2TP + Динамический IP».

Укажите логин и пароль два раза, которые вы получили при подключении к интернету. Так же пропишите «Адрес VPN-сервера». Для Билайн это — tp.internet.beeline.ru. Проверьте, стоит ли галочка возле «Соединятся автоматически». Нажмите на кнопку «Применить».

Если вы все указали правильно, то роутер должен подключится к интернету. Подключение будет с зеленым значком и статусом «Соединено».

Подключение PPPoE на DIR-300A (ТТК, Дом.ru, Ростелеком)

Так же, как я показывал выше, создаем новое подключение, и выбираем тип подключения PPPoE.

Укажите логин и пароль, которые указаны в договоре по подключению к интернету, и нажмите кнопку «Применить».

Если маршрутизатор не хочет подключатся к интернету, то звоните в поддержку провайдера, и уточняйте настройки. Скорее всего, неправильно указываете какие-то параметры.

Смотрите статс соединения на вкладке WAN:

Только после того, как подключение к интернету будет установлено, есть смысл продолжать настройку маршрутизатора.

Протоколы группы FHRP (First Hop Redundancy Protocols)

FHRP (Протокол резервирования первого перехода) — это группа протоколов способные обеспечить клиентов отказоустойчивым шлюзом.

Что за первый переход такой?. У нас есть коммутируемая среда (SW1) и есть Internet . Internet это маршрутизируемая среда . И для того чтобы перейти из коммутируемой среды , в маршрутизируемую среду для того чтобы выйти в интернет , как раз эти роутеры(R1,R2,VR — Virtual Router) обеспечивают данный переход и для того ,чтобы обеспечить отказоустойчивость этого перехода , его нужно резервировать . А потому и называется протоколы резервирования первого перехода.

И все протоколы группы FHRP будут работать в единой логике: R1 , R2 будут прикидываться VR и в случае отказа одного из маршрутизаторов, то его работу возьмет другой.

  • Forwarding Router ( FR ) — это роутер ,который данный момент активен и маршрутизирует трафик .
  • Standby Router ( SR ) — это роутер ,который стоит в резерве и ждет , когда накроется FR ,чтобы перехватите его работу на себя , в случае сбоя маршрутизатора.
  • FHRPs — это группа ,а значит пришло время познакомить вас с этими протоколами.
    • HSRP (Hot Standby Router Protocol) — Проприетарный протокол разработанный Cisco;
    • VRRP (Virtual Router Redundancy Protocol) — Свободный протокол ,сделан на основе HSRP;
    • GLBP (Gateway Load Balancing Protocol) — Проприетарный протоколCisco , обеспечивающий распределение нагрузки на несколько маршрутизаторов( шлюзов) используя 1 виртуальный адрес.
    • CARP( Common Address Redundancy Protocol) — свободный , разработан как часть OpenBSD , портирован во FreeBSD.

Итак начнём с HSRP

Коротко табличка с адресацией:

Протокол HSRP рассчитан на 2 роутера, 3 это уже лишний и с этим уже справиться протокол GLBP

Предположим ,что R3 это маршрутизатор выхода в интернет и для этого мы поднимем на нём Loopback 1 с адресом 200.200.200.200 и пропишем его в маршруте по умолчанию. Между маршрутизаторами будет настроен RIPv2 и будут анонсированы 2 классовые сети( network 10.0.0.0 и network 192.168.0.0) для простоты анонсирования маршрутов.

R2,R0 настраивается также. А теперь по порядку , настроим HSRP:

  • Router(config)# interface fa 0/1 — переходим на интерфейс fast ethernet 0/1 (этот интерфейс смотрит в локальную сеть на коммутатор )
  • Router(config-if)# ip address 192.168.0.2 255.255.255.0 — задаем ip адрес для физического интерфейса
  • Router(config-if)# standby 1 ip 192.168.0.254 — задаем виртуальный ip адрес (который будет основным шлюзом для свитчей, смотрящих на конфигурируемый роутер). У обоих роутеров он одинаковый
  • Router(config-if)# stanby 1 priority 110 — устанавливаем приоритет данного роутера в 110 (по умолчанию приоритет 100)
  • Router(config-if)# standby 1 preempt — задаем режим приемтинга
  • Router(config-if)# standby 1 authentication md5 key-string MyPassword — задаем аутентификацию, если необходимо. Пароль будет передаваться с защитой алгоритмом хеширования md5, пароль будет MyPassword
  • R3(config-if)# standby 1 timers 100 255 — регулировка таймеров hsrp, где 100 — hello интервал в секундах (как часто посылаются пакеты hello пакеты keep-alive) и 255 — hold interval в секундах (через какой промежуток времени признавать соседа недоступным)
  • Router(config-if)# standby 1 preempt delay minimum 300 — настройка времени задержки (в секундах), через которое роутер будет становиться главным. Эта команда требуется для того,чтобы сначала отработали другие протоколы,прежде чем заработает HSRP . Пример: OSPF включенный на роутере в большой сети не успеет передать маршруты все ,а тут сразу заработает HSRP ,естественно он знать все маршруты не будет,а значить и стабильно гнать трафик тоже. Как раз время delay он будет использовать для того,чтобы дать OSPF передать все маршруты и после этого вкл HSRP.
Читать еще:  Сбой шифрования андроид что делать

TRACKING

Также полезно вешать TRACK на интерфейсы ,так как HSRP работает только в сторону ,куда направлен интерфейс ,то он не сможет отработать,когда упадут линки ,смотрящие на роутеры выше.(в данном случае это R3)

  • Router(config)# track 1 interface fa0/1 line-protocol — отслеживаем состояние интерфейса fa0/1, если он падает, то сработает объект отслеживания track 1.
  • Router(config-if)# standby 1 track 1 decrement 15 — если сработает объект отслеживания track 1, то текущий приоритет будет понижен на 15 единиц.
  • Router(config-if)# standby 1 track 1 fa0/1 20 — работает только в HSRP. Позволяет отслеживать интерфейс без дополнительного создания объекта отслеживания.

R1,R2,R0 будут настраиваться одинаково, принцип сохраняется.

А теперь нюансы HSRP

При работе нескольких VLAN , HSRP может идти трафик не совсем рационально. Представим ,что R1 это root primary за 10 VLAN, а R3 это ACTIVE router в HSRP . Это значит ,что любой трафик за этот VLAN будет идти следующим образом:VPC — R3 — R1 — R4 вместо того,чтобы идти напрямую VPC — R3 — R4

Поэтому рекомендуют использовать HSRP version 2(по умолчанию вкл 1 максимум 255 процессов,а во 2 их 4095) и использовать наилучший приоритет для того роутера, который сейчас в сети root primary за текущий VLAN. И хорошей практикой будет если номер VLAN будет совпадать с номером процесса HSRP. ( № HSRP = VLAN )

3 Роутера в HSRP не имеет смысла держать,так как он всё равно будет в состоянии Listen и включиться только тогда,если active пропадет, standby займет его место , и только тогда он перейдет в состоянии standby.(речь идет о 3 роутере) Тоже самое будет касаться 4,5 . n роутеров.

Бывает и другая ситуация ,когда не сам линк от R1 падает ,а устройство находящиеся за ним,к примеру SW2 упал link до R3. Проблему способен решить сервис SLA — Service Level Agreement.

Суть его проста,он ping сервис до провайдера и если он падает ,то отрабатывает track.

  • Router(config)# ip sla 1 — создаем зонд
  • Router(config-ip-sla)# icmp-echo 215.215.215.2 source-interface e0/2 — посылаем icmp echo ping на 215.215.215.2
  • Router(config-ip-sla-echo)# frequency 10 — посылаем icmp echo ping с частотой каждые 10 секунд
  • Router(config)# ip sla schedule 1 start-time now life forever — задаем расписание работы ip sla. В данном случае зон будет запущен прямо сейчас, при этом время окончания не задано (навсегда)
  • Router(config)# track 1 ip sla 1 reachability — устанавливаем объект отслеживания на доступность того хоста, на который посылаем icmp echo ping
  • Router(config)# ip route 0.0.0.0 0.0.0.0 2.2.2.2 track 1 — направляем трафик по этому маршруту если объект трекинга track 1 работает (хост пингуется)
  • Router(config)# ip route 0.0.0.0 0.0.0.0 3.3.3.3 10 — если не пингуется, направляем трафик в интернет по другому маршруту (Внимание! Здесь важно задать именно плохую метрику, например 10, иначе будут работать оба маршрута! (балансировка))
  • Router# show track 1 — показать состояние объекта отслеживания

Настройка VRRP не сильно отличается от HSRP . Настраивается он также как и HSRP, только вместо standby используется vrrp. Router(config-if)# vrrp 1 ip 192.168.1.1 — включение vrrp. Проще пройтись по отличиям ,чем заново описывать все команды.

  1. У VRRP тоже только 2 состояния Master и Backup(HSRP active и standby)
  2. Preempt включен по умолчанию (HSRP он отключен)
  3. При падении линка VRRP проводит выборы роутера(HSRP имеет запасной). Главного выбирают по IP адресу, когда проводят выборы.
  4. Поддержка Аутентификации в VRRP отсутствует (RFC отсутствует),но в Cisco она реализована(HSRP по умолчанию)
  5. VRRP по умолчанию hello таймер равен 1 секунде , dead таймер равен 3(у HSRP 3 и 10 соответственно)
  6. Виртуальный адрес может совпадать с адресом интерфейса(HSRP такой адрес не даст прописать)
  7. Использует Multicast HSRP равен 224.0.0.2 ( version 1) 224.0.0.102 (version 2) ,а VRRP 224.0.0.18
  8. Может отслеживать только объекты , а HSRP и интерфейсы , и объекты.(смотри раздел tracking)

Сб июл 18, 2020 22:59:36

Короче разобрался я со своим роутером)) Всё работает. Тут подсказали — https://gamedev.ru/code/forum/?id=50491&page=2

Для проверки я взял простой роутер и посмотрел как там работает UDP (проброска портов отключена). Измерил все тайминги))

Схема такая: сервер (10.0.0.1) — (WAN | роутер | LAN) — сервер (192.168.0.1)

1. Из внешней сети (10.0.0.1) во внутреннюю (192.168.0.1) попасть невозможно так как порты на роутере закрыты.
2. Из внутренней сети (192.168.0.1) во внешнюю сеть (10.0.0.1) попасть можно.))
3. Допустим сервер (192.168.0.1) отправляет UDP пакет серверу (10.0.0.1).
4. Роутер делает запись в таблице NAT (связка «порт == IP» ).
5. После отправки UDP пакета роутер включает таймер примерно на 20 секунд.
6. Если по истечении 20 секунд ответ так и не пришёл, роутер удаляет из таблицы NAT запись о сокете. После этого из внешней сети (10.0.0.1) во внутреннюю (192.168.0.1) попасть невозможно.
7. Допустим ответ пришёл. Тогда роутер устанавливает таймер примерно на 30 секунд.

9. При каждом новом пакете роутер автоматически устанавливает таймер примерно на 2. 3 минуты.
10. Если пакетов больше нет, то через 2. 3 минуты срабатывает тайм-аут и роутер удаляет из таблицы NAT запись о сокете. После этого из внешней сети (10.0.0.1) во внутреннюю (192.168.0.1) попасть невозможно.
11. При передачи пакетов порты (Source port и Destination port) роутер не меняет. Роутер меняет только IP (Source IP и Destination IP).

12. Вывод: Для поддержания связи по UDP надо непрерывно что-то передавать. например пустые пакеты. не реже чем каждые 2. 3 минуты )) Чтоб не срабатывал тайм-аут и роутер удаляет из таблицы NAT запись о сокете.

По сути это получается тот же самый keep-alive как в TCP. или как в браузере. или как в HTTP(S)/WebSockets.
Пипец))

Ну зато теперь я точно знаю как работает мой роутер))

Ссылка на основную публикацию
Статьи c упоминанием слов:
Adblock
detector